Miscellaneous
Miscellaneous other things.
Seconfig XP Other software Miscellaneous
Stats
  • Page visited 601209 times
Site search
Page translation
Visitor locations
Other counters
  Search Results  
Dāvis's tech blog - Problems installing Apache HTTP Server
A few days ago I wanted to install Apache web server on a computer running Windows XP (development system), but .msi installer of current version (2.2.11) didn't initialize properly - after some seconds message consisting of Installation Wizard Interrupted and The Installation Wizard was interrupted before Apache HTTP Server 2.2.11 could be completely installed. appeared on installation wizard and the only enabled button was Finish.
I created Windows Installer log file by invoking MSIEXEC /I apache_2.2.11-win32-x86-openssl-0.9.8i.msi /L*v LogFileName.txt. In log file I immediately noticed these two lines:
Action ended 16:50:09: ResolveServerName. Return value 3.
MSI (c) (D0:18) [16:50:09:437]: Doing action: SetupCompleteError
I tried to enumerate areas where this particular computer was different from an average workstation/server and tried to find out what exactly could cause such error. I paid special attention to network configuration, so one of first things that came into my mind was seven network interfaces (some physical, some virtual) of this workstation. About five network interfaces were online (Connected), so I disabled (simply right clicked on these network interfaces in Control Panel - Network Connections and selected Disable) some of them, leaving only two NICs online. This solved my problem - Apache web server installation wizard initialized properly and I had no further problems installing Apache HTTPD. After installation I, of course, re-enabled those network interfaces.
Posted on 2009.03.10. 20:45

RCI at 2009.04.03. 03:07
Thanks Davis! This worked for me as well. I only had to disable the Microsoft Loopback Adapter which I added a while back. This did the trick! Thanks again!

-R

Post a comment
Share |
© 2006-2012